summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:05 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-20 08:54:11 -0500
commit9290e943cfa03e7b671b7de5165e5f21225a1c8f (patch)
tree25a5363a88ca326d7e36ed58c22745eb03ed409f /gnu/packages/golang.scm
parent52fdcf299dc0510697198f153c868f4fabee56a4 (diff)
gnu: Add go-github-com-rivo-tview.
* gnu/packages/golang.scm (go-github-com-rivo-tview): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 33ea1f40a8..03481d99e9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6011,6 +6011,36 @@ systems.")
(modify-inputs (package-inputs go-github-com-gdamore-tcell)
(prepend go-golang-org-x-term go-golang-org-x-sys)))))
+(define-public go-github-com-rivo-tview
+ (package
+ (name "go-github-com-rivo-tview")
+ (version "0.0.0-20220703182358-a13d901d3386")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rivo/tview")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gf1m3ndbc3kgxpv0ryq9a1ahijg6m896sc9k7dvwfjd8vy0q0yd"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/rivo/tview"))
+ (propagated-inputs (list go-golang-org-x-term
+ go-golang-org-x-sys
+ go-github-com-rivo-uniseg
+ go-github-com-mattn-go-runewidth
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-gdamore-tcell-v2))
+ (home-page "https://github.com/rivo/tview")
+ (synopsis "Rich Interactive Widgets for Terminal UIs")
+ (description
+ "The tview package implements rich widgets for terminal based user
+interfaces. The widgets provided with this package are useful for data
+exploration and data entry.")
+ (license license:expat)))
+
(define-public go-github-com-xo-terminfo
(package
(name "go-github-com-xo-terminfo")