summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 00:16:28 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit9ae4da0018557c690d6a177ab7cfda5feaaa1e75 (patch)
treef00ed58ba1410c4cdfe45fc9a8fa935095f7c9e2 /gnu/packages/golang.scm
parent4df431e6cb56c36c557c452c6005c336df731724 (diff)
gnu: go-github-com-operatorfoundation-ed25519: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-operatorfoundation-ed25519): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: Ia6a28bb8ad138b921e386f3b4d2dee65b43806d1
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3f740810ff..5ecbfaa904 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9872,37 +9872,6 @@ compressed streams in Go.")
(description "@{gitconfig} is a package to get configuration values from gitconfig.")
(license license:expat)))
-(define-public go-github-com-operatorfoundation-ed25519
- (let ((commit "b22b4bd3ddef042eec45f3ee135cd40281fde2b4")
- (revision "0"))
- (package
- (name "go-github-com-operatorfoundation-ed25519")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/OperatorFoundation/ed25519")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xrzqrjlghkgd1cy5rj4khryn4f59vas2vzrxc6d8jpj5ijf3xkv"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/OperatorFoundation/ed25519"
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'remove-test-data
- (lambda* (#:key import-path #:allow-other-keys)
- (delete-file-recursively
- (string-append "src/" import-path "/testdata"))
- #t)))))
- (home-page "https://github.com/OperatorFoundation/ed25519")
- (synopsis "Ed25519 for go")
- (description "Package ed25519 implements the Ed25519 signature
-algorithm.")
- (license license:bsd-3))))
-
(define-public go-github-com-akosmarton-papipes
(let ((commit "3c63b4919c769c9c2b2d07e69a98abb0eb47fe64")
(revision "0"))