summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-05 21:52:17 +0800
committerLudovic Courtès <ludo@gnu.org>2023-07-01 23:38:27 +0200
commitac481a00501d93f07332ae603f50a91068e15d29 (patch)
treeecb6dd11f9ef66dba390f5c034f99b644efe6a0b /gnu/packages/golang.scm
parentb7708699d93d2104f9fd949e97c5757ed9eb5c39 (diff)
gnu: Add go-github-com-tdewolff-parse-v2.
* gnu/packages/golang.scm (go-github-com-tdewolff-parse-v2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 471a150366..e802d8b3b3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3384,6 +3384,30 @@ per-goroutine.")
(description "The @code{walker} function is a faster, parallel version, of
@code{filepath.Walk}")))
+(define-public go-github-com-tdewolff-parse-v2
+ (package
+ (name "go-github-com-tdewolff-parse-v2")
+ (version "2.6.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdewolff/parse")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dqki9ima079k9a3l72igmx5dml8qsl9z8rzw8a433f4gjhlv320"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/tdewolff/parse/v2"))
+ (native-inputs
+ (list go-github-com-tdewolff-test))
+ (home-page "https://github.com/tdewolff/parse")
+ (synopsis "Go parsers for web formats")
+ (description
+ "This package contains several lexers and parsers written in Go.")
+ (license license:expat)))
+
(define-public go-github-com-tdewolff-test
(package
(name "go-github-com-tdewolff-test")