summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:24:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:37:51 +0000
commitb4107ca3ad8bb8a6b8e669c298be2f14ff0237da (patch)
treefaf8ed39aaa618a0048f6610ca7b1c301304d96a /gnu/packages/golang.scm
parentcd49133bfe97d6336adc85b1b587e335721cbdaa (diff)
gnu: go-github-com-hashicorp-hcl-v2: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-hashicorp-hcl-v2): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ife07c1ca7b0ba7241955767ebd2430a8e60aec90
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3fa3ed7ebf..d12902290e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3304,37 +3304,6 @@ command-line parsers.")
(home-page "https://github.com/tj/docopt")
(license license:expat)))
-(define-public go-github-com-hashicorp-hcl-v2
- (package
- (name "go-github-com-hashicorp-hcl-v2")
- (version "2.11.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hashicorp/hcl")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0f9flmmkj7fr1337fc56cqy73faq87ix375hnz3id4wc023przv1"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/hashicorp/hcl/v2"))
- (native-inputs
- (list go-github-com-davecgh-go-spew))
- (inputs
- (list go-github-com-agext-levenshtein go-github-com-mitchellh-go-wordwrap
- go-github-com-zclconf-go-cty
- go-github-com-apparentlymart-go-textseg-v13))
- (synopsis "Go implementation of HashiCorp Configuration Language V2")
- (description
- "This package contains the main implementation of the @acronym{HCL,
-HashiCorp Configuration Language}. HCL is designed to be a language for
-expressing configuration which is easy for both humans and machines to read.")
- (home-page "https://github.com/hashicorp/hcl")
- (license license:mpl2.0)))
-
(define-public govulncheck
(package
(name "govulncheck")