summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-05 12:54:51 -0800
committerLeo Famulari <leo@famulari.name>2023-03-28 16:26:09 -0400
commitbcec46eee260efe9bc6d41c30c4480ab82296158 (patch)
tree268e32e584a0572d26fb35e95807199caab7dfc9 /gnu/packages/golang.scm
parent6d9dbdffcbe695482bfb30a9e77261ccfa285b6e (diff)
gnu: Add go-github-com-jacobsa-ogletest.
* gnu/packages/golang.scm (go-github-com-jacobsa-ogletest): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b513b0d5b0..fdde6f7cae 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1274,6 +1274,41 @@ Test for C++ and Google JS Test.")
"Package oglemock provides a mocking framework for unit tests.")
(license license:asl2.0))))
+(define-public go-github-com-jacobsa-ogletest
+ (let ((commit "80d50a735a1108a2aeb7abc4a988d183f20c5292")
+ (revision "0"))
+ (package
+ (name "go-github-com-jacobsa-ogletest")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacobsa/ogletest")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lbwbxzr75g65q07ry5k4kglxqs3ym7xkvqznzm55rm3qk76v83r"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jacobsa/ogletest"
+ ;; These tests should be made working
+ #:tests? #f))
+ (native-inputs (list
+ go-github-com-jacobsa-oglematchers
+ go-github-com-jacobsa-oglemock
+ go-github-com-jacobsa-reqtrace
+ go-golang-org-x-net))
+ (home-page "https://github.com/jacobsa/ogletest")
+ (synopsis "Expressive unit tests")
+ (description
+ "Package ogletest provides a framework for writing expressive unit tests. It
+integrates with the builtin testing package, so it works with the gotest
+command. Unlike the testing package which offers only basic capabilities for
+signalling failures, it offers ways to express expectations and get nice failure
+messages automatically.")
+ (license license:asl2.0))))
+
(define-public go-github-com-kataras-golog
(package
(name "go-github-com-kataras-golog")