summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-05 12:54:48 -0800
committerLeo Famulari <leo@famulari.name>2023-03-28 16:26:08 -0400
commitbd89aed9367fd8a4541a6905f0d8403dca73277d (patch)
tree2e0ba08528b72c7b44d2a86e254dc25bf8d0bfd1 /gnu/packages/golang.scm
parent8810be06f2164fe93f5cb3ebee427f41c3512eed (diff)
gnu: Add go-github-com-aperturerobotics-jacobsa-crypto.
* gnu/packages/golang.scm (go-github-com-aperturerobotics-jacobsa-crypto): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 39d40fe0b8..dc46c96080 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1186,6 +1186,37 @@ networks where it would otherwise be blocked or heavily throttled.")
"This is a repository containing Go bindings for writing FUSE file systems.")
(license license:bsd-3))))
+(define-public go-github-com-aperturerobotics-jacobsa-crypto
+ (let ((commit "b1eb679742a8deed015a4406384eea6bd985d08a")
+ (revision "0"))
+ (package
+ (name "go-github-com-aperturerobotics-jacobsa-crypto")
+ (version (git-version "1.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aperturerobotics/jacobsa-crypto")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16dxigj8m6q18xqsy72iq287rh4fw0y0b9yqlw0qkclb8379n1z2"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/aperturerobotics/jacobsa-crypto"
+ ;; Source-only package.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package.
+ (delete 'build))))
+ (home-page "https://github.com/aperturerobotics/jacobsa-crypto")
+ (synopsis "Cryptography missing from the Go standard library")
+ (description
+ "This repository contains Go packages related to cryptographic standards that are
+not included in the Go standard library.")
+ (license license:asl2.0))))
+
(define-public go-github-com-kataras-golog
(package
(name "go-github-com-kataras-golog")