summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2023-01-17 18:44:51 -0700
committerChristopher Baines <mail@cbaines.net>2023-02-07 00:05:52 +0100
commited4effffd24baf7b1f5e5a3f8d064e425ed529d7 (patch)
treea11a91c07656f7b35a58fa4c3834c7be19b2cd30 /gnu/packages/golang.scm
parent195780da771109c9b6177d52ee779e024c65cddd (diff)
gnu: Add go-github-com-jba-templatecheck.
* gnu/packages/golang.scm (go-github-com-jba-templatecheck): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b3710559ac..4e88ceec0c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8585,6 +8585,32 @@ file system operations.")
legal Go source code, and returns an error when detects that it cannot.")
(license license:expat)))
+(define-public go-github-com-jba-templatecheck
+ (package
+ (name "go-github-com-jba-templatecheck")
+ (version "0.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jba/templatecheck")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12iwkidz4p6wdl65jfddqxls80mv879k2rpb42dj7y4dja5advlc"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jba/templatecheck"))
+ (propagated-inputs (list go-github-com-google-safehtml))
+ (home-page "https://github.com/jba/templatecheck")
+ (synopsis "Checks Go templates for problems")
+ (description
+ "Package templatecheck checks Go templates for problems. It can detect
+many errors that are normally caught only during execution. Use templatecheck
+in tests to find template errors early, and along template execution paths
+that might only rarely be reached.")
+ (license license:expat)))
+
(define-public go-github-com-jbenet-go-context
(let ((commit "d14ea06fba99483203c19d92cfcd13ebe73135f4")
(revision "1"))