summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:10 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:30 -0400
commitf6a03a8ba69ead8ab3bc39f9f750ac6d036c6b0b (patch)
tree76dce03d207ca9edce93fd5394167eebb3d5d7b3 /gnu/packages/golang.scm
parent4e65fb5b336197c0f20aba76ba8e44e9197a7a5b (diff)
gnu: go-golang-org-x-lint: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-golang-org-x-lint): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2503fca0b6..e5dd116766 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11477,34 +11477,6 @@ be used as both a binary and a library.")
(native-inputs '())
(inputs '())))
-(define-public go-golang-org-x-lint
- (let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
- (revision "0"))
- (package
- (name "go-golang-org-x-lint")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/lint")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0ms3rs5hvpnm9bxbr5f9743i7hn2bbmqdmvzxq6nmi0f24ypv1l3"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/lint"
- #:tests? #f)) ;; TODO: Fix tests
- (propagated-inputs
- (list go-golang-org-x-tools))
- (home-page "https://golang.org/x/lint")
- (synopsis "Linter for Go source code")
- (description
- "This is a linter for Go source code. Unlike gofmt, it doesn't
-reformat the source code, it only prints out style mistakes.")
- (license license:bsd-3))))
-
(define-public go-github-com-kisielk-gotool
(package
(name "go-github-com-kisielk-gotool")