summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-05 12:54:53 -0800
committerLeo Famulari <leo@famulari.name>2023-03-28 16:26:09 -0400
commite64286d6e018c6f06fc4f790958626d07700a873 (patch)
treea2d92edb1d7c4b3a6a8b7ff071ae4d01b46db46b /gnu/packages/golang.scm
parent48f8f9048d6fb0058368923d407c216a2c0513ed (diff)
gnu: Add go-github-com-pkg-xattr.
* gnu/packages/golang.scm (go-github-com-pkg-xattr): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8bab117224..9fb2346783 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1406,6 +1406,36 @@ terminals.")
aid data snapshotting.")
(license license:isc)))
+(define-public go-github-com-pkg-xattr
+ (package
+ (name "go-github-com-pkg-xattr")
+ (version "0.4.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/xattr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qg4zh0d8m4adaiicsd0cpw0w6g8sk01f4jz7jyxgirh1wfcsqyz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/pkg/xattr"))
+ (native-inputs (list go-golang-org-x-sys))
+ (home-page "https://github.com/pkg/xattr")
+ (synopsis "Support for extended file system attributes")
+ (description
+ "Package xattr provides support for extended attributes on Linux, Darwin and
+FreeBSD. Extended attributes are name:value pairs permanently associated with
+files or directories. They are similar to the environment strings associated with
+a process. An attribute may be defined or undefined. If defined, its value may
+be empty or non-empty. You can find more details here:
+@@url{https://en.wikipedia.org/wiki/Extended_file_attributes,
+https://en.wikipedia.org/wiki/Extended_file_attributes}
+.")
+ (license license:bsd-2)))
+
(define-public go-github-com-shadowsocks-go-shadowsocks2
(package
(name "go-github-com-shadowsocks-go-shadowsocks2")