summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-05 12:54:54 -0800
committerLeo Famulari <leo@famulari.name>2023-03-28 16:26:10 -0400
commitf6eb16ca3e20c6fa2a6fce9077c79e78aac39693 (patch)
tree484ca200b6c51a56dfadcb0211b8107ac5f2dae5 /gnu/packages/golang.scm
parente64286d6e018c6f06fc4f790958626d07700a873 (diff)
gnu: Add go-github-com-rfjakob-eme.
* gnu/packages/golang.scm (go-github-com-rfjakob-eme): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9fb2346783..da0ae52a61 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1436,6 +1436,29 @@ https://en.wikipedia.org/wiki/Extended_file_attributes}
.")
(license license:bsd-2)))
+(define-public go-github-com-rfjakob-eme
+ (package
+ (name "go-github-com-rfjakob-eme")
+ (version "1.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rfjakob/eme")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yrbhvy0337mf12fp8p4sy8ry8r3w2qfdf8val5hj07p2lri0cqk"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/rfjakob/eme"))
+ (home-page "https://github.com/rfjakob/eme")
+ (synopsis "EME for Go")
+ (description
+ "EME (ECB-Mix-ECB or, clearer, Encrypt-Mix-Encrypt) is a wide-block encryption
+mode developed by Halevi and Rogaway.")
+ (license license:expat)))
+
(define-public go-github-com-shadowsocks-go-shadowsocks2
(package
(name "go-github-com-shadowsocks-go-shadowsocks2")