summaryrefslogtreecommitdiff
path: root/gnu/packages/gprolog.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-26 16:43:08 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-26 16:43:08 +0200
commita9db7d10b6e4e86fb2b87a4161db3b1f202002fd (patch)
tree4a22481ab65447d8bc1cc307a76a884a7e7bbee9 /gnu/packages/gprolog.scm
parente33d9d6f09874f83bb5a03f49cb969a84588e10e (diff)
parent2b6bdf7eb3c95716ac107ea6caea2e0b7077ae77 (diff)
Merge branch 'master' into core-updates
Conflicts: Makefile.am gnu/packages/autotools.scm gnu/packages/guile.scm gnu/packages/python.scm gnu/packages/shishi.scm guix/gnu-maintenance.scm guix/scripts/build.scm guix/scripts/gc.scm guix/scripts/package.scm guix/scripts/substitute-binary.scm guix/ui.scm nix/nix-daemon/guix-daemon.cc test-env.in tests/nar.scm tests/store.scm
Diffstat (limited to 'gnu/packages/gprolog.scm')
-rw-r--r--gnu/packages/gprolog.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/gprolog.scm b/gnu/packages/gprolog.scm
index ba84d9a836..7f7cbe0178 100644
--- a/gnu/packages/gprolog.scm
+++ b/gnu/packages/gprolog.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,15 +26,15 @@
(define-public gprolog
(package
(name "gprolog")
- (version "1.4.2")
+ (version "1.4.3")
(source
(origin
(method url-fetch)
- (uri (string-append "http://www.gprolog.org/gprolog-"
- version ".tar.gz"))
+ (uri (string-append "mirror://gnu/gprolog/gprolog-" version
+ ".tar.gz"))
(sha256
(base32
- "0y25c2gwz41i6g28qyfjklrmanzgk0c8cr4jn2s7s8qgd9dnm1fm"))))
+ "16yl6q9ydx9d8lphg9xkk53l1m0fq0kpvrhry8njsxhhncazm4j2"))))
(build-system gnu-build-system)
(arguments
`(#:phases (alist-cons-before
@@ -45,9 +46,7 @@
(("= /bin/sh") (string-append "= " (which "sh")))))
%standard-phases)))
(home-page "https://www.gnu.org/software/gprolog/")
- (synopsis
- "GNU Prolog, a free Prolog compiler with constraint solving over
-finite domains")
+ (synopsis "Prolog compiler")
(description
"GNU Prolog is a free Prolog compiler with constraint solving over
finite domains developed by Daniel Diaz.
@@ -69,4 +68,4 @@ interface, sockets).
GNU Prolog also includes an efficient constraint solver over finite domains.
This opens contraint logic programming to the user combining the power of
constraint programming to the declarativity of logic programming.")
- (license (list gpl2+ lgpl3+)))) \ No newline at end of file
+ (license (list gpl2+ lgpl3+))))