summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-27 13:42:50 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-27 14:08:56 -0500
commit608f0c9f27c3597b2a82a4bec6c5a704b5222eb2 (patch)
tree11bf0985f366494f580ce95fa5b4149514295a95 /gnu/packages/graph.scm
parent68e4ec9ccfcb0c7bb76408ffedf9cfdbbc341c37 (diff)
gnu: Remove python-louvain-0.7.
* gnu/packages/graph.scm (python-louvain-0.7): Delete variable.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm52
1 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index f5d527d66b..560764bb33 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -311,58 +311,6 @@ subplots, multiple-axes, polar charts, and bubble charts.")
algorithm for community detection in large networks.")
(license license:bsd-3)))
-(define-public python-louvain-0.7
- (package
- (name "python-louvain")
- (version "0.7.1")
- ;; The tarball on Pypi does not include the tests.
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vtraag/louvain-igraph")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1g6b5c2jgwagnhnqh859g61h7x6a81d8hm3g6mkin6kzwafww3g2"))))
- (build-system python-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'build 'pretend-version
- ;; The version string is usually derived via setuptools-scm, but
- ;; without the git metadata available this fails.
- (lambda _
- (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))
- (add-before 'build 'find-igraph
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "IGRAPH_EXTRA_INCLUDE_PATH"
- (string-append (assoc-ref inputs "igraph")
- "/include/igraph:"
- (getenv "C_INCLUDE_PATH")))
- (setenv "IGRAPH_EXTRA_LIBRARY_PATH"
- (getenv "LIBRARY_PATH")))))))
- (propagated-inputs
- (list python-ddt python-igraph))
- (inputs
- (list igraph))
- (native-inputs
- (list pkg-config
- python-pytest
- python-setuptools-scm
- python-wheel))
- (home-page "https://github.com/vtraag/louvain-igraph")
- (synopsis "Algorithm for methods of community detection in large networks")
- (description
- "This package provides an implementation of the Louvain algorithm for use
-with igraph. Louvain is a general algorithm for methods of community
-detection in large networks.
-
-This package has been superseded by the @code{leidenalg} package and should
-not be used for new projects.")
- (license license:gpl3+)))
-
(define-public faiss
(package
(name "faiss")