summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-30 22:59:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-30 23:09:46 +0200
commitca2516f0653c33494701ad02638bf5d7c5c74f25 (patch)
treecc25e9f704a8baf710f666a0c8538df6d0e470ab /gnu/packages/graph.scm
parent7c8f3dfa34bf644066035a352ddf8f5191b3ec80 (diff)
gnu: python-leidenalg: Update to 0.8.10.
* gnu/packages/graph.scm (python-leidenalg): Update to 0.8.10. [arguments]: Patch setup.py. [native-inputs]: Remove python-setuptools; add python-setuptools-scm.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 6d1575a0bd..0b8e76f676 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -495,14 +495,14 @@ Faiss library.")))
(define-public python-leidenalg
(package
(name "python-leidenalg")
- (version "0.7.0")
+ (version "0.8.10")
(source
(origin
(method url-fetch)
(uri (pypi-uri "leidenalg" version))
(sha256
(base32
- "15fwld9hdw357rd026mzcwpah5liy4f33vc9x9kwy37g71b2rjf1"))))
+ "1hbvagp1yyazvl7cid7mii5263qi48lpkq543n5w71qysgz1f0v7"))))
(build-system python-build-system)
(arguments
'(#:tests? #f ;tests are not included
@@ -510,12 +510,14 @@ Faiss library.")))
(add-after 'unpack 'fix-requirements
(lambda _
(substitute* "setup.py"
+ (("self.external = False")
+ "self.external = True")
+ (("self.use_pkgconfig = False")
+ "self.use_pkgconfig = True")
(("python-igraph >=")
"igraph >=")))))))
(native-inputs
- ;; XXX: setuptools >= 58 as shipped with Python 3.9+ removes support
- ;; for lib2to3, so use this older variant.
- (list pkg-config python-setuptools))
+ (list pkg-config python-setuptools-scm))
(inputs
(list igraph))
(propagated-inputs