summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-07 14:11:55 +0100
committerMarius Bakke <marius@gnu.org>2023-01-07 21:04:26 +0100
commitedbacab9953144a3aa204f9f0eee1584ef321a8f (patch)
tree375b90e501ed9094821796355bf57286052e02a9 /gnu/packages/graph.scm
parenta47c475678c3647be918ebc97cced1e8a2306993 (diff)
gnu: Use old setuptools in packages that relies on use_2to3 conversion.
This fixes a regression since 520cdf80581669646ff61e9f18f3b27045556e76 where the use_2to3 functionality was removed from setuptools. * gnu/packages/graph.scm (python-louvain)[native-inputs]: Change from PYTHON-SETUPTOOLS to PYTHON-SETUPTOOLS-57. * gnu/packages/python-check.scm (python-parameterizedtestcase)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-anyjson)[native-inputs]: Add PYTHON-SETUPTOOLS-57. * gnu/packages/bioinformatics.scm (python-pyvcf)[native-inputs]: Change from PYTHON-SETUPTOOLS-FOR-TENSORFLOW to PYTHON-SETUPTOOLS-57.
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 52c63c8654..a2f771799f 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -295,7 +295,7 @@ subplots, multiple-axes, polar charts, and bubble charts.")
(base32 "0sx53l555rwq0z7if8agirjgw4ddp8r9b949wwz8vlig03sjvfmp"))))
(build-system python-build-system)
(native-inputs
- (list python-setuptools)) ;for use_2to3 support
+ (list python-setuptools-57)) ;for use_2to3 support
(propagated-inputs
(list python-networkx python-numpy))
(home-page "https://github.com/taynaud/python-louvain")