summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-29 22:34:57 +0200
committerMarius Bakke <marius@gnu.org>2021-07-29 22:34:57 +0200
commitb029be2ee0f81cdcbc14240ff426408085ab0a40 (patch)
treeed6d0e1bfdadfd28e1eb804e43763b793baa0b42 /gnu/packages/graph.scm
parentbc55f3091bac4677df0cf020381c554921fea179 (diff)
parentffb381856d0c6cc1a557b789f6b377cfa17002a0 (diff)
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/bioinformatics.scm gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/emacs-xyz.scm gnu/packages/gpodder.scm gnu/packages/music.scm gnu/packages/patches/glibc-bootstrap-system.patch gnu/packages/python-xyz.scm gnu/packages/shells.scm gnu/packages/statistics.scm
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 42bd37a07a..c9486935ae 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -539,7 +539,7 @@ transformed into common image formats for display or printing.")
(define-public python-graph-tool
(package
(name "python-graph-tool")
- (version "2.37")
+ (version "2.43")
(source (origin
(method url-fetch)
(uri (string-append
@@ -547,7 +547,7 @@ transformed into common image formats for display or printing.")
version ".tar.bz2"))
(sha256
(base32
- "0w2i4d4zyk051zkykcg0ksngspajznwmp523hbsx50xnxc6jliyz"))))
+ "0v58in4rwk9fhjarjw6xfxpx5zz2z13sy3yvd14b5kr0884yw6sz"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -563,23 +563,23 @@ transformed into common image formats for display or printing.")
"python"))))
"/site-packages/"))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("gcc-10" ,gcc-10)
- ("ncurses" ,ncurses)))
+ `(("gcc-10" ,gcc-10)
+ ("ncurses" ,ncurses)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("python" ,python-wrapper)
- ("boost" ,boost)
+ `(("boost" ,boost)
+ ("cairomm" ,cairomm)
+ ("cgal" ,cgal)
("expat" ,expat)
("gmp" ,gmp)
- ("cgal" ,cgal)
- ("sparsehash" ,sparsehash)
("gtk+" ,gtk+)
- ("cairomm" ,cairomm)))
+ ("python" ,python-wrapper)
+ ("sparsehash" ,sparsehash)))
(propagated-inputs
- `(("python-scipy" ,python-scipy)
+ `(("python-matplotlib" ,python-matplotlib)
("python-numpy" ,python-numpy)
("python-pycairo" ,python-pycairo)
- ("python-matplotlib" ,python-matplotlib)))
+ ("python-scipy" ,python-scipy)))
(synopsis "Manipulate and analyze graphs with Python efficiently")
(description "Graph-tool is an efficient Python module for manipulation
and statistical analysis of graphs (a.k.a. networks). Contrary to most other