summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2023-04-27 15:54:33 +0000
committerLudovic Courtès <ludo@gnu.org>2023-06-18 23:23:31 +0200
commit73f6785bdf9eb0c70e8f6c557dff4d717f4ca5c0 (patch)
tree139eac6cc68380b27a297d4ef58739e1c29bcbbb /gnu/packages/graphics.scm
parenta82130de50d2c84d77492d9aa43e4b7f4b06b4b2 (diff)
gnu: openmw-openscenegraph: Update to Nov 2022 commit.
* gnu/packages/graphics.scm (openmw-openscenegraph): Update to Nov 2022 commit. [arguments]: Sync the plugin flags with the mentioned wiki page. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index bccfe89d55..3a65b96919 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1464,11 +1464,11 @@ in Julia).")
(define-public openmw-openscenegraph
;; OpenMW prefers its own fork of openscenegraph:
;; https://wiki.openmw.org/index.php?title=Development_Environment_Setup#OpenSceneGraph.
- (let ((commit "36a962845a2c87a6671fd822157e0729d164e940"))
+ (let ((commit "69cfecebfb6dc703b42e8de39eed750a84a87489"))
(hidden-package
(package
(inherit openscenegraph)
- (version (git-version "3.6" "1" commit))
+ (version (git-version "3.6" "2" commit))
(outputs (list "out"))
(source
(origin
@@ -1479,7 +1479,7 @@ in Julia).")
(file-name (git-file-name (package-name openscenegraph) version))
(sha256
(base32
- "05yhgq3qm5q277y32n5sf36vx5nv5qd3zlhz4csgd3a6190jrnia"))))
+ "1qayk2gklm8zvss90dcjfxv6717rvcmwmgmgyy1qzkli67a0zbw2"))))
(arguments
(substitute-keyword-arguments (package-arguments openscenegraph)
((#:configure-flags flags)
@@ -1487,14 +1487,14 @@ in Julia).")
#~(append
'("-DBUILD_OSG_PLUGINS_BY_DEFAULT=0"
"-DBUILD_OSG_PLUGIN_OSG=1"
+ "-DBUILD_OSG_PLUGIN_DAE=1"
"-DBUILD_OSG_PLUGIN_DDS=1"
"-DBUILD_OSG_PLUGIN_TGA=1"
"-DBUILD_OSG_PLUGIN_BMP=1"
"-DBUILD_OSG_PLUGIN_JPEG=1"
"-DBUILD_OSG_PLUGIN_PNG=1"
- "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
- ;; The jpeg plugin requires conversion between integers and booleans
- "-DCMAKE_CXX_FLAGS=-fpermissive")
+ "-DBUILD_OSG_PLUGIN_FREETYPE=1"
+ "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0")
#$flags))
((#:phases phases)
#~(modify-phases #$phases
@@ -2612,4 +2612,3 @@ environment. It supports drawing freehand as well as basic shapes and text.
It features cut-and-paste for irregular regions or polygons.")
(home-page "https://www.gnu.org/software/gpaint/")
(license license:gpl3+)))
-