summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-06 21:25:43 +0200
committerMarius Bakke <marius@gnu.org>2020-06-06 21:25:43 +0200
commit7ce1b5e7b74d6409d0bd0bc4272f65edc34fd9df (patch)
tree504a250d235a3bc39571e6af1c755077390a371f /gnu/packages/graphics.scm
parentf20d1cfb51ed14f325da000406807076323f70bc (diff)
parentb69ca4d234db8fe2750e9b0d6b6139a5a89a4da6 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm174
1 files changed, 174 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 664e3fab45..b2bc63b9d0 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,6 +43,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
@@ -51,6 +53,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -61,11 +64,13 @@
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages jemalloc)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages plotutils)
#:use-module (gnu packages pth)
#:use-module (gnu packages pulseaudio) ; libsndfile, libsamplerate
#:use-module (gnu packages python)
@@ -143,6 +148,61 @@ objects!")
(home-page "http://www.fox-toolkit.org")
(license license:lgpl2.1+)))
+(define-public autotrace
+ (let ((commit "travis-20190624.59")
+ (version-base "0.40.0"))
+ (package
+ (name "autotrace")
+ (version (string-append version-base "-"
+ (if (string-prefix? "travis-" commit)
+ (string-drop commit 7)
+ commit)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/autotrace/autotrace.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mk4yavy42dj0pszr1ggnggpvmzs4ds46caa9wr55cqsypn7bq6s"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ ;; See: https://github.com/autotrace/autotrace/issues/27.
+ (add-after 'unpack 'include-spline.h-header
+ (lambda _
+ (substitute* "Makefile.am"
+ ((".*src/types.h.*" all)
+ (string-append all "\t\tsrc/spline.h \\\n")))
+ #t))
+ ;; See: https://github.com/autotrace/autotrace/issues/26.
+ (replace 'check
+ (lambda _
+ (invoke "sh" "tests/runtests.sh"))))))
+ (native-inputs
+ `(("which" ,which)
+ ("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("gettext" ,gettext-minimal)))
+ (inputs
+ `(("glib" ,glib)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("imagemagick" ,imagemagick)
+ ("pstoedit" ,pstoedit)))
+ (home-page "https://github.com/autotrace/autotrace")
+ (synopsis "Bitmap to vector graphics converter")
+ (description "AutoTrace is a utility for converting bitmap into vector
+graphics. It can trace outlines and midlines, effect color reduction or
+despeckling and has support for many input and output formats. It can be used
+with the @command{autotrace} utility or as a C library, @code{libautotrace}.")
+ (license (list license:gpl2+ ;for the utility itself
+ license:lgpl2.1+))))) ;for use as a library
+
(define-public blender
(package
(name "blender")
@@ -328,6 +388,120 @@ quaternions and other useful 2D and 3D math functions. Iex is an
exception-handling library.")
(license license:bsd-3)))
+(define-public lib2geom
+ ;; Use the latest master commit, as the 1.0 release suffer build problems.
+ (let ((revision "1")
+ (commit "42e119d94934a9514c61571cfb6b4af503ece082"))
+ (package
+ (name "lib2geom")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/inkscape/lib2geom.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "195rs0kdbs8w62irha1nwy83bccz04wglmk578qrj1mky7fc4rjv"))
+ (patches
+ ;; Patch submitted to upstream (see:
+ ;; https://gitlab.com/inkscape/lib2geom/merge_requests/17).
+ (search-patches "lib2geom-enable-assertions.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Fix py2geom module initialization (see:
+ ;; https://gitlab.com/inkscape/lib2geom/merge_requests/18).
+ (substitute* "src/py2geom/__init__.py"
+ (("_py2geom") "py2geom._py2geom"))
+ #t))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:imported-modules ((guix build python-build-system)
+ ,@%cmake-build-system-modules)
+ #:configure-flags '("-D2GEOM_BUILD_SHARED=ON"
+ "-D2GEOM_BOOST_PYTHON=ON"
+ ;; Compiling the Cython bindings fail (see:
+ ;; https://gitlab.com/inkscape/lib2geom/issues/21).
+ "-D2GEOM_CYTHON_BINDINGS=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-python-lib-install-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((python-version (@ (guix build python-build-system)
+ python-version))
+ (python-maj-min-version (python-version
+ (assoc-ref inputs "python")))
+ (site-package (string-append
+ (assoc-ref outputs "out")
+ "/lib/python" python-maj-min-version
+ "/site-packages")))
+ (substitute* '("src/cython/CMakeLists.txt"
+ "src/py2geom/CMakeLists.txt")
+ (("PYTHON_LIB_INSTALL \"[^\"]*\"")
+ (format #f "PYTHON_LIB_INSTALL ~s" site-package))))
+ #t)))))
+ (native-inputs `(("python" ,python-wrapper)
+ ("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)))
+ (inputs `(("cairo" ,cairo)
+ ("pycairo" ,python-pycairo)
+ ("double-conversion" ,double-conversion)
+ ("glib" ,glib)
+ ("gsl" ,gsl)))
+ (propagated-inputs
+ `(("boost" ,boost))) ;referred to in 2geom/pathvector.h.
+ (home-page "https://gitlab.com/inkscape/lib2geom/")
+ (synopsis "C++ 2D graphics library")
+ (description "2geom is a C++ library of mathematics for paths, curves,
+and other geometric calculations. Designed for vector graphics, it tackles
+Bézier curves, conic sections, paths, intersections, transformations, and
+basic geometries.")
+ ;; Because the library is linked with the GNU Scientific Library
+ ;; (GPLv3+), the combined work must be licensed as GPLv3+ (see:
+ ;; https://gitlab.com/inkscape/inkscape/issues/784).
+ (license license:gpl3+))))
+
+(define-public pstoedit
+ (package
+ (name "pstoedit")
+ (version "3.75")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/pstoedit/pstoedit/"
+ version "/pstoedit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kv46g2wsvsvcngkavxl5gnw3l6g5xqnh4kmyx4b39a01d8xiddp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ghostscript" ,ghostscript)
+ ("imagemagick" ,imagemagick)
+ ("libplot" ,plotutils)
+ ("libjpeg" ,libjpeg-turbo)
+ ("zlib" ,zlib))) ;else libp2edrvmagick++.so fails to link
+ (home-page "http://www.pstoedit.net/")
+ (synopsis "Converter for PostScript and PDF graphics")
+ (description "The @code{pstoedit} utility allows translating graphics
+in the PostScript or PDF (Portable Document Format) formats to various
+other vector formats such as:
+@itemize
+@item Tgif (.obj)
+@item gnuplot
+@item xfig (.fig)
+@item Flattened PostScript
+@item DXF, a CAD (Computed-Aided Design) exchange format
+@item PIC (for troff/groff)
+@item MetaPost (for usage with TeX/LaTeX)
+@item LaTeX2e picture
+@item GNU Metafile (for use with plotutils/libplot)
+@item Any format supported by ImageMagick
+@end itemize")
+ (license license:gpl2+)))
+
(define-public ogre
(package
(name "ogre")