summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-11-11 20:44:07 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-11 20:44:07 -0500
commitab307cbb586584dab715ffcc6cf123d02ddcb6bf (patch)
treedcdf5ae56f61bb5f8533598138851a291fe18830 /gnu/packages/graphics.scm
parent8d0a3bfcdae4bc9dd15e7fb0488dce8f16e8f867 (diff)
gnu: skia: Fix build.
The "SkRuntimeBlender_GPU" test started to fail with a segmentation fault after recent updates, possibly with mesa to 23.2.1. However, this doesn't seem to be true on all hardware, as Andronikos reported success on IRC and Bordeaux also built the previous derivation. * gnu/packages/graphics.scm (skia)[phases]: Add "SkRuntimeBlender_GPU" to tests that are skipped in the check phase. Change-Id: I4077ae89a58049628a90f8abd23395f9ba89047a
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 00e273b853..9e2efaa7fb 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2204,6 +2204,10 @@ Cflags: -I${includedir}~%" #$output #$version)))))
"_" "_" "_" "Codec_partialAnim"
"_" "_" "_" "Codec_InvalidImages"
"_" "_" "_" "Codec_GifInterlacedTruncated"
+ ;; This test started failing possibly after mesa
+ ;; being updated to 23.2.1 and possibly only on some
+ ;; hardware.
+ "_" "_" "_" "SkRuntimeBlender_GPU"
"_" "_" "_" "SkText_UnicodeText_Flags"
"_" "_" "_" "SkParagraph_FontStyle"
"_" "_" "_" "flight_animated_image"