summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-07 10:58:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:07:22 +0100
commit3d388fe3d0475f2e991ae061cc1364529a97af42 (patch)
treed7eab125e55ed658edf4b0b5d677a0373076ee5f /gnu/packages/graphviz.scm
parent75331dc6e690e790cccfa7ec0b936ff60e7f517d (diff)
gnu: python-graphviz: Update to 0.20.1.
* gnu/packages/graphviz.scm (python-graphviz): Update to 0.20.1. [build-system]: Use pyproject-build-system. [arguments]: Remove custom "check" phase; add "prepare-check" phase. [native-inputs]: Remove python-mock.
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 51c1de3932..7c2cb1eae0 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2015, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2018, 2019, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
@@ -32,6 +32,7 @@
(define-module (gnu packages graphviz)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -180,27 +181,25 @@ interfaces for other technical domains.")
(define-public python-graphviz
(package
(name "python-graphviz")
- (version "0.13.2")
+ (version "0.20.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "graphviz" version ".zip"))
(sha256
(base32
- "009alrilzx0v7kl41khbq7k6k8b8pxyvbsi1b1ai933f6kpbxb30"))))
- (build-system python-build-system)
+ "1y1b956r01kg7qarkkrivhn71q64k0gbq6bcybd4gfd3v95g2n4c"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests #:allow-other-keys)
- (if tests
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%"))
- #t)))))
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'prepare-chec
+ ;; Needed for fontconfig cache directories
+ (lambda _ (setenv "HOME" (getcwd)))))))
(native-inputs
(list unzip
;; For tests.
graphviz
- python-mock
python-pytest
python-pytest-cov
python-pytest-mock))