summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-07 17:06:44 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-07 17:07:16 +0200
commit0b6e4f82fcc906c431a575ab68183ed3c1eaa220 (patch)
treea28e15a81a4d36ebe22134abf3ec124987c62f6a /gnu/packages/groff.scm
parent7f0980839e4d9d3c7e06301bcbb2eb292bd7dbee (diff)
gnu: groff: Remove dependency on netpbm.
* gnu/packages/groff.scm (groff)[inputs]: Remove 'netpbm'.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 46e1ccf233..d7f45d4fc7 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -44,8 +44,13 @@
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;12MiB of PS, PDF, HTML, and examples
- (inputs `(("ghostscript" ,ghostscript)
- ("netpbm" ,netpbm)))
+
+ ;; Note: groff's HTML backend uses executables from netpbm when they are in
+ ;; $PATH. In practice, not having them doesn't prevent it from install its
+ ;; own HTML doc, nor does it change its capabilities, so we removed netpbm
+ ;; from 'inputs'.
+
+ (inputs `(("ghostscript" ,ghostscript)))
(native-inputs `(("bison" ,bison)
("perl" ,perl)
("psutils" ,psutils)