summaryrefslogtreecommitdiff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-29 10:31:27 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:01 +0100
commit6d82239a5fe834ebf73965705b8eaff4d9adb7f7 (patch)
tree25b7a06f0e1c56eafbd0b61eb97476b048390e43 /gnu/packages/groff.scm
parent7ed11ca491f8e2b754ea0c0cf2cd5be83c8cf1a6 (diff)
gnu: ronn-ng: Fix build.
* gnu/packages/groff.scm (ronn-ng)[arguments]: Add 'patch-test phase and update style.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm49
1 files changed, 28 insertions, 21 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 33a059053c..94c0f23d7a 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -32,6 +32,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ruby)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages ruby)
#:use-module (gnu packages bison)
@@ -229,27 +230,33 @@ It is typically used to display man pages on a web site.")
"1slxfg57cabmh98fw507z4ka6lwq1pvbrqwppflxw6700pi8ykfh"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'extract-gemspec 'fix-gemspec-mustache
- (lambda _
- (substitute* "ronn-ng.gemspec"
- (("(<mustache>.freeze.*~>).*(\".*$)" all start end)
- (string-append start " 1.0" end)))
- #t))
- (add-after 'wrap 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref %outputs "out") "/bin/ronn")))
- (wrap-program prog
- `("PATH" ":" suffix ,(map
- (lambda (exp_inpt)
- (string-append
- (assoc-ref %build-inputs exp_inpt)
- "/bin"))
- '("ruby-kramdown"
- "ruby-mustache"
- "ruby-nokogiri")))))
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-test
+ (lambda _
+ ;; TODO This should be removed once the upstream fix is released
+ ;; https://github.com/apjanke/ronn-ng/commit/e194bf62b1d0c0828cc83405e60dc5ece829e62f
+ (substitute* "test/test_ronn_document.rb"
+ (("YAML\\.load\\(@doc\\.to_yaml\\)")
+ "YAML.load(@doc.to_yaml, permitted_classes: [Time])"))))
+ (add-after 'extract-gemspec 'fix-gemspec-mustache
+ (lambda _
+ (substitute* "ronn-ng.gemspec"
+ (("(<mustache>.freeze.*~>).*(\".*$)" all start end)
+ (string-append start " 1.0" end)))))
+ (add-after 'wrap 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref %outputs "out") "/bin/ronn")))
+ (wrap-program prog
+ `("PATH" ":" suffix ,(map
+ (lambda (exp_inpt)
+ (string-append
+ (assoc-ref %build-inputs exp_inpt)
+ "/bin"))
+ '("ruby-kramdown"
+ "ruby-mustache"
+ "ruby-nokogiri"))))))))))
(inputs
(list ruby-kramdown ruby-mustache ruby-nokogiri))
(synopsis