summaryrefslogtreecommitdiff
path: root/gnu/packages/grub.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-25 11:20:21 -0500
committerLeo Famulari <leo@famulari.name>2016-11-25 11:20:21 -0500
commitde32aa74b4f7762e887e80047804c42d495ab841 (patch)
treebc37856ba9036563aa9ca7809ea3e8cefcb670e9 /gnu/packages/grub.scm
parentd46491779e18cf614caeeb1b4becbd9171c64416 (diff)
parentd66cbd1adc799b08e66cd912822c6220499b4876 (diff)
Merge branch 'master' into python-build-system
Diffstat (limited to 'gnu/packages/grub.scm')
-rw-r--r--gnu/packages/grub.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index b920be9ea2..ef7395e95e 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -127,9 +127,16 @@
(("set -e") "exit 77\nset -e"))
#t)))))
(inputs
- `(;; ("lvm2" ,lvm2)
- ("gettext" ,gettext-minimal)
+ `(("gettext" ,gettext-minimal)
+
+ ;; Depend on LVM2 for libdevmapper, used by 'grub-probe' and
+ ;; 'grub-install' to recognize mapped devices (LUKS, etc.)
+ ("lvm2" ,lvm2)
+
+ ;; Depend on mdadm, which is invoked by 'grub-probe' and 'grub-install'
+ ;; to determine whether the root file system is RAID.
("mdadm" ,mdadm)
+
("freetype" ,freetype)
;; ("libusb" ,libusb)
;; ("fuse" ,fuse)