summaryrefslogtreecommitdiff
path: root/gnu/packages/grub.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-15 01:22:06 -0400
committerLudovic Courtès <ludo@gnu.org>2015-10-28 12:04:03 +0100
commit04e0eac1ed80c0ecba5a21658e951959b5e3a059 (patch)
treeb891a35ee3c0bcba22298860ffc186cec1f572d2 /gnu/packages/grub.scm
parent0431ed00e4556bb2f96a6d0974e833821419026b (diff)
gnu: grub: Use modify-phases and other minor cleanups.
* gnu/packages/grub.scm (grub)[arguments]: Use modify-phases. Return #t from 'patch-stuff' phase. Add 'patch-stuff' phase after 'unpack' instead of before 'patch-source-shebangs'. [inputs]: Add comment noting that 'fuse' would be a desirable input.
Diffstat (limited to 'gnu/packages/grub.scm')
-rw-r--r--gnu/packages/grub.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index b1da394835..4a7dca8945 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,25 +85,28 @@
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-werror")
- #:phases (alist-cons-before
- 'patch-source-shebangs 'patch-stuff
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "grub-core/Makefile.in"
- (("/bin/sh") (which "sh")))
+ #:phases (modify-phases %standard-phases
+ (add-after
+ 'unpack 'patch-stuff
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "grub-core/Makefile.in"
+ (("/bin/sh") (which "sh")))
- ;; Make the font visible.
- (copy-file (assoc-ref inputs "unifont") "unifont.bdf.gz")
- (system* "gunzip" "unifont.bdf.gz")
+ ;; Make the font visible.
+ (copy-file (assoc-ref inputs "unifont") "unifont.bdf.gz")
+ (system* "gunzip" "unifont.bdf.gz")
- ;; TODO: Re-enable this test when we have Parted.
- (substitute* "tests/partmap_test.in"
- (("set -e") "exit 77")))
- %standard-phases)))
+ ;; TODO: Re-enable this test when we have Parted.
+ (substitute* "tests/partmap_test.in"
+ (("set -e") "exit 77"))
+
+ #t)))))
(inputs
`(;; ("lvm2" ,lvm2)
("gettext" ,gnu-gettext)
("freetype" ,freetype)
;; ("libusb" ,libusb)
+ ;; ("fuse" ,fuse)
("ncurses" ,ncurses)))
(native-inputs
`(("unifont" ,unifont)