summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-18 16:30:21 +0200
committerMarius Bakke <marius@gnu.org>2022-09-18 16:30:21 +0200
commit80c76f5d8eaa0aff40c08eac19a62e0e7957a7c8 (patch)
tree68938c2e5ed14adc2af9ef9be6691b1948175f39 /gnu/packages/gstreamer.scm
parentcbe461f2d497554fd667429cd9db5ee990c7fadb (diff)
parent2266ec5eb1bcc2c87baa27297a4205eebf325424 (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index aa49f89155..a1cf662e37 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -476,7 +476,21 @@ the GStreamer multimedia framework.")
(arguments
(list #:phases
#~(modify-phases %standard-phases
- #$@%common-gstreamer-phases)))
+ #$@%common-gstreamer-phases
+ #$@(if (string-prefix? "i686" (or (%current-target-system)
+ (%current-system)))
+ ;; FIXME: These tests consistently fail in the Guix CI:
+ ;; https://issues.guix.gnu.org/57868
+ '((add-after 'unpack 'disable-systemclock-test
+ (lambda _
+ (substitute* "tests/check/gst/gstsystemclock.c"
+ (("tcase_add_test \\(tc_chain, \
+test_stress_cleanup_unschedule.*")
+ "")
+ (("tcase_add_test \\(tc_chain, \
+test_stress_reschedule.*")
+ "")))))
+ '()))))
(propagated-inputs
;; In gstreamer-1.0.pc:
;; Requires: glib-2.0, gobject-2.0
@@ -880,7 +894,7 @@ model to base your own plug-in on, here it is.")
openjpeg
;; openni2
opensles
- openssl
+ openssl-1.1
opus
orc
pango