summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-08 08:54:33 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:31 -0400
commit864a7478e85d99f08122b0120ad695164ee55dbe (patch)
tree9dbffed823b23d1add87f7102636410c6b0bec1f /gnu/packages/gstreamer.scm
parent30b6431441a4c0f46c853e503a53927dc143987b (diff)
gnu: gstreamer: Do not reference Python.
* gnu/packages/gstreamer.scm (gstreamer) [native-inputs]: Replace python-wrapper with python. [arguments]: List python in #:disallowed-references. Add a 'do-not-capture-python phase.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm46
1 files changed, 29 insertions, 17 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index f33a30a02b..7aa9500620 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -475,28 +475,40 @@ the GStreamer multimedia framework.")
"0aisl8nazcfi4b5j6fz8zwpp0k9csb022zniz65b2pxxpdjayzb0"))))
(build-system meson-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- #$@%common-gstreamer-phases
- #$@(if (string-prefix? "i686" (or (%current-target-system)
- (%current-system)))
- ;; FIXME: These tests consistently fail in the Guix CI:
- ;; https://issues.guix.gnu.org/57868
- '((add-after 'unpack 'disable-systemclock-test
- (lambda _
- (substitute* "tests/check/gst/gstsystemclock.c"
- (("tcase_add_test \\(tc_chain, \
+ (list
+ #:disallowed-references (list python)
+ #:phases
+ #~(modify-phases %standard-phases
+ #$@%common-gstreamer-phases
+ #$@(if (string-prefix? "i686" (or (%current-target-system)
+ (%current-system)))
+ ;; FIXME: These tests consistently fail in the Guix CI:
+ ;; https://issues.guix.gnu.org/57868
+ '((add-after 'unpack 'disable-systemclock-test
+ (lambda _
+ (substitute* "tests/check/gst/gstsystemclock.c"
+ (("tcase_add_test \\(tc_chain, \
test_stress_cleanup_unschedule.*")
- "")
- (("tcase_add_test \\(tc_chain, \
+ "")
+ (("tcase_add_test \\(tc_chain, \
test_stress_reschedule.*")
- "")))))
- '()))))
+ "")))))
+ '())
+ (add-after 'patch-shebangs 'do-not-capture-python
+ (lambda _
+ ;; The patch-source-shebangs phase causes the following build
+ ;; script to reference Python in its shebang, which is
+ ;; unnecessary.
+ (substitute* (string-append #$output
+ "/libexec/gstreamer-1.0/"
+ "gst-plugins-doc-cache-generator")
+ (((which "python3"))
+ "/usr/bin/env python3")))))))
(propagated-inputs
;; In gstreamer-1.0.pc:
;; Requires: glib-2.0, gobject-2.0
;; Requires.private: gmodule-no-export-2.0 libunwind libdw
- (list elfutils ; libdw
+ (list elfutils ;libdw
glib libunwind))
(native-inputs
(list bash-completion
@@ -506,7 +518,7 @@ test_stress_reschedule.*")
gobject-introspection
perl
pkg-config
- python-wrapper))
+ python))
(inputs
(list gmp libcap
;; For tests.