summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-01 16:04:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-01 16:44:50 +0300
commit3fdeb158d81532627ba08821baeef21ae77db32a (patch)
tree34f72d7bf3595c12a6d4668855cc2d2c69b51fba /gnu/packages/gstreamer.scm
parentcef95d4faae1bf620ad4f451cf5167d73c041ea4 (diff)
gnu: gst-plugins-base: Build with orc on all platforms.
* gnu/packages/gstreamer.scm (gst-plugins-base)[propagated-inputs]: Build with orc on all platforms.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index fc3f3eaaa6..d3c177ddbf 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -532,19 +532,13 @@ This package provides the core library and elements.")
"17rw8wj1x1bg153m9z76pdvgz5k93m3riyalfpzq00x7h7fv6c3y"))))
(build-system meson-build-system)
(propagated-inputs
- (cons* glib ;required by gstreamer-sdp-1.0.pc
- gstreamer ;required by gstreamer-plugins-base-1.0.pc
- libgudev ;required by gstreamer-gl-1.0.pc
- ;; wayland-client.h is referred to in
- ;; include/gstreamer-1.0/gst/gl/wayland/gstgldisplay_wayland.h
- wayland
- ;; XXX: Do not enable Orc optimizations on ARM systems because
- ;; it leads to two test failures.
- ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/issues/683
- (if (string-prefix? "arm" (or (%current-target-system)
- (%current-system)))
- '()
- (list orc)))) ;required by gstreamer-audio-1.0.pc
+ (list glib ;required by gstreamer-sdp-1.0.pc
+ gstreamer ;required by gstreamer-plugins-base-1.0.pc
+ libgudev ;required by gstreamer-gl-1.0.pc
+ ;; wayland-client.h is referred to in
+ ;; include/gstreamer-1.0/gst/gl/wayland/gstgldisplay_wayland.h
+ wayland
+ orc)) ;required by gstreamer-audio-1.0.pc
(inputs
;; TODO: Add libvorbisidec
(list alsa-lib