summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-02-05 23:05:41 -0500
committerMark H Weaver <mhw@netris.org>2015-02-05 23:07:29 -0500
commitce4a347fe9397d94d4b7aba4c84fd9cbf8f0167a (patch)
tree97fdc6d2efde570ce79b0a5dc9f23133274d9914 /gnu/packages/gstreamer.scm
parent353e34a626a43f2fc4e278373b90b9e43a45082f (diff)
gnu: orc: Disable the 'test-limits' and 'exec_opcodes_sys' tests.
* gnu/packages/gstreamer.scm (orc)[arguments]: Disable the 'test-limits' and 'exec_opcodes_sys' tests, which fail on some machines.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 7d8ef83a6c..7afb9c4218 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -1,7 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,6 +53,18 @@
(base32
"1ryz1gfgrxcj806cakcblxf0bcwq8p2mw8k86fs3f5wlwayawzkn"))))
(build-system gnu-build-system)
+ (arguments `(#:phases
+ (alist-cons-before
+ 'check 'disable-faulty-test
+ (lambda _
+ ;; XXX Disable the 'test-limits' and 'exec_opcodes_sys'
+ ;; tests, which fail on some machines. See:
+ ;; https://bugzilla.gnome.org/show_bug.cgi?id=735273
+ (substitute* '("testsuite/test-limits.c"
+ "testsuite/exec_opcodes_sys.c")
+ (("if \\(error\\) return 1;")
+ "if (error) return 77;")))
+ %standard-phases)))
(home-page "http://code.entropywave.com/orc/")
(synopsis "Oil runtime compiler")
(description