summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-30 22:06:57 +0100
committerAndreas Enge <andreas@enge.fr>2013-10-30 22:06:57 +0100
commitf506ed920cdc105f090507e3cf8fc447f61756dc (patch)
tree85233875e7476bc0925b6c5da8bfba1e85bafac8 /gnu/packages/gstreamer.scm
parent94f48f98f05239c4bd5b8281042452e68d8f99b2 (diff)
gnu: Add gstreamer-0.10.
* gnu/packages/gstreamer.scm (gstreamer-0.10): New variable. * gnu/packages/patches/gstreamer-0.10-bison3.patch, gnu/packages/patches/gstreamer-0.10-silly-test.patch: New files. * gnu-system.am (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 7478dc3188..ffdb4b83ad 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -21,12 +21,14 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages glib)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages python))
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xml))
(define-public gstreamer
(package
@@ -64,6 +66,29 @@ simple plugin with a clean, generic interface.
This package provides the core library and elements.")
(license lgpl2.0+)))
+(define-public gstreamer-0.10
+ (package (inherit gstreamer)
+ (version "0.10.36")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1nkid1n2l3rrlmq5qrf5yy06grrkwjh3yxl5g0w58w0pih8allci"))
+ (patches
+ (list (search-patch "gstreamer-0.10-bison3.patch")
+ (search-patch "gstreamer-0.10-silly-test.patch")))))
+ (inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("glib" ,glib)
+ ("libxml2" ,libxml2)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)))))
+
(define-public gst-plugins-base
(package
(name "gst-plugins-base")