summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2013-12-15 12:01:56 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-15 22:31:19 +0100
commitc4c4cc05979f2a2d0212963c5fe1b940d63a0958 (patch)
treeffe05f66ed9236ac03ac219449924e36a87134c4 /gnu/packages/gstreamer.scm
parente766f699be12e5ad044c415a1b8658cfe0a18c9b (diff)
gnu: Move numerous "inputs" which should be "native-inputs".
* gnu/packages/avahi.scm, gnu/packages/cdrom.scm, gnu/packages/cryptsetup.scm, gnu/packages/curl.scm, gnu/packages/emacs.scm, gnu/packages/fontutils.scm, gnu/packages/gdb.scm, gnu/packages/geeqie.scm, gnu/packages/ghostscript.scm, gnu/packages/glib.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnuzilla.scm, gnu/packages/graphviz.scm, gnu/packages/groff.scm, gnu/packages/gstreamer.scm, gnu/packages/gtk.scm, gnu/packages/gv.scm, gnu/packages/imagemagick.scm, gnu/packages/irssi.scm, gnu/packages/kde.scm, gnu/packages/libcanberra.scm, gnu/packages/libtiff.scm, gnu/packages/linux.scm, gnu/packages/lvm.scm, gnu/packages/mp3.scm, gnu/packages/netpbm.scm, gnu/packages/parted.scm, gnu/packages/pdf.scm, gnu/packages/pulseaudio.scm, gnu/packages/qemu.scm, gnu/packages/qt.scm, gnu/packages/ratpoison.scm, gnu/packages/rdf.scm, gnu/packages/slim.scm, gnu/packages/texlive.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vpn.scm, gnu/packages/w3m.scm, gnu/packages/xml.scm, gnu/packages/xnee.scm, gnu/packages/xorg.scm, gnu/packages/zip.scm: Move some build-time dependencies from `inputs' to `native-inputs'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 58625be073..6ebd8c399b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -43,10 +43,10 @@
(base32
"0c0irk85jd2cihm5pmf4zxhlpg08qpxjcqv1l9qn2n3h2gsaj2lf"))))
(build-system gnu-build-system)
- (inputs
+ (inputs `(("glib" ,glib)))
+ (native-inputs
`(("bison" ,bison)
("flex" ,flex)
- ("glib" ,glib)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
@@ -82,10 +82,10 @@ This package provides the core library and elements.")
(search-patch "gstreamer-0.10-silly-test.patch")))))
(propagated-inputs
`(("libxml2" ,libxml2)))
- (inputs
+ (inputs `(("glib" ,glib)))
+ (native-inputs
`(("bison" ,bison)
("flex" ,flex)
- ("glib" ,glib)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python" ,python-2)))))
@@ -106,9 +106,10 @@ This package provides the core library and elements.")
;; FIXME: Add more dependencies for further plugins.
(inputs
`(("glib" ,glib)
- ("gstreamer" ,gstreamer)
- ("pkg-config" ,pkg-config)
- ("python-wrapper" ,python-wrapper)))
+ ("gstreamer" ,gstreamer)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)))
(arguments
`(#:tests? #f))
;; All tests pass except for one:
@@ -147,6 +148,7 @@ This package provides an essential exemplary set of elements.")
"0jp6hjlra98cnkal4n6bdmr577q8mcyp3c08s3a02c4hjhw5rr0z"))))
(inputs
`(("glib" ,glib)
- ("gstreamer" ,gstreamer-0.10)
- ("pkg-config" ,pkg-config)
+ ("gstreamer" ,gstreamer-0.10)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
("python" ,python-2)))))