summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-17 00:36:28 +0200
committerMarius Bakke <marius@gnu.org>2022-09-17 00:36:28 +0200
commit09efea1ce07414ad8666b2ac2e3ac07db491cd21 (patch)
treec0853c43da8d8eced6a42c9bbd5c3a9ba03f965a /gnu/packages/gstreamer.scm
parent706e6c3c8f9aa19c6ec22d4bbd77d09624dbf671 (diff)
gnu: gstreamer: Disable failing tests on i686 again.
* gnu/packages/gstreamer.scm (gstreamer)[arguments]: Disable two tests on i686-linux.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 943f46eeb5..a6687f411f 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -479,7 +479,21 @@ the GStreamer multimedia framework.")
(arguments
(list #:phases
#~(modify-phases %standard-phases
- #$@%common-gstreamer-phases)))
+ #$@%common-gstreamer-phases
+ #$@(if (string-prefix? "i686" (or (%current-target-system)
+ (%current-system)))
+ ;; FIXME: These tests consistently fail in the Guix CI:
+ ;; https://issues.guix.gnu.org/57868
+ '((add-after 'unpack 'disable-systemclock-test
+ (lambda _
+ (substitute* "tests/check/gst/gstsystemclock.c"
+ (("tcase_add_test \\(tc_chain, \
+test_stress_cleanup_unschedule.*")
+ "")
+ (("tcase_add_test \\(tc_chain, \
+test_stress_reschedule.*")
+ "")))))
+ '()))))
(propagated-inputs
;; In gstreamer-1.0.pc:
;; Requires: glib-2.0, gobject-2.0