summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/gstreamer.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm23
1 files changed, 20 insertions, 3 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 77b62264ff..36cdd70207 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -353,8 +353,7 @@ playback by a single audio device. You can also pre-load samples, and play them
back without having to send all the data for the sound. Network transparency is
also built in, so you can play sounds on one machine, and listen to them on
another.")
- (home-page "https://web.archive.org/web/20160528230227/
-http://www.tux.org/~ricdude/overview.html")
+ (home-page "https://web.archive.org/web/20160528230227/http://www.tux.org/~ricdude/overview.html")
(license
(list
;; Libraries.
@@ -731,6 +730,17 @@ model to base your own plug-in on, here it is.")
(home-page "https://gstreamer.freedesktop.org/")
(license license:lgpl2.0+)))
+(define-public gst-plugins-good-qt
+ (package
+ (inherit gst-plugins-good)
+ (name "gst-plugins-good-qt")
+ (inputs
+ (modify-inputs (package-inputs gst-plugins-good)
+ (prepend qtbase-5
+ qtdeclarative-5
+ qtwayland-5
+ qtx11extras)))))
+
(define-public gst-plugins-bad
(package
(name "gst-plugins-bad")
@@ -788,6 +798,14 @@ model to base your own plug-in on, here it is.")
;; FIXME: Why is this failing.
((".*elements/dash_mpd\\.c.*") "")
+ ;; This test is flaky on at least some architectures.
+ ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
+ #$@(if (member (%current-system)
+ '("i686-linux" "aarch64-linux" "riscv64-linux"))
+ `((("'elements/camerabin\\.c'\\]\\],")
+ "'elements/camerabin.c'], true, ],"))
+ '())
+
;; These tests are flaky and occasionally time out:
;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
((".*elements/curlhttpsrc\\.c.*") "")
@@ -833,7 +851,6 @@ model to base your own plug-in on, here it is.")
curl
directfb
;; dssim
- faac
faad2
flite
fluidsynth