summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-27 17:10:55 +0200
committerMarius Bakke <marius@gnu.org>2022-08-27 17:10:55 +0200
commitad384816fe260be98bc53701d9d761197ef162fc (patch)
treeff06eb12983b7cbd972c3153404bb3952e2f28c0 /gnu/packages/gtk.scm
parentd08411ffd0a36a6b67a238be69d32c9f74101389 (diff)
parentfb3d90b8f31c4b1e2e3d427544c6610f3fe1ce55 (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ab0f3e2467..428273ee89 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2190,13 +2190,13 @@ information.")
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))))
(find-files (string-append out "/bin")))))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("itstool" ,itstool)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python-wrapper" ,python-wrapper)))
+ (list gettext-minimal
+ `(,glib "bin")
+ gobject-introspection
+ itstool
+ perl
+ pkg-config
+ python-wrapper))
(inputs
(list bc
dblatex
@@ -2210,7 +2210,6 @@ information.")
python-lxml
python-parameterized
python-pygments
- python-unittest2
source-highlight
yelp-tools))
(home-page "https://wiki.gnome.org/DocumentationProject/GtkDoc")
@@ -2235,8 +2234,8 @@ with some extra work.")
(define-public gtk-doc/stable
(hidden-package
(package/inherit gtk-doc
- (inputs (alist-replace "dblatex" `(,dblatex/stable)
- (package-inputs gtk-doc))))))
+ (inputs (modify-inputs (package-inputs gtk-doc)
+ (replace "dblatex" dblatex/stable))))))
(define-public gtk-engines
(package