summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-20 12:06:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:43 +0200
commit3dc6253e878fa6a4cb7670c62249ed05ebb85e40 (patch)
treef0554cd0797fed08e358eae755cabf40ef298cd3 /gnu/packages/gtk.scm
parenta90043cfe8db47b916913f9fa2a8e768587ac9a2 (diff)
gnu: at-spi2-core: Skip tests when cross-compiling.
* gnu/packages/gtk.scm (at-spi2-core)[arguments]: When cross compiling skip the custom 'check phase. Change-Id: Ibc15a829d632bce8331dc70df6dc3b36b4a479a4
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 47d4c1808f..cc33c9f672 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -806,7 +806,8 @@ ever use this library.")
;; The CI test suite fails completely on powerpc-linux.
;; The name org.gnome.SessionManager was not provided by any .service
;; TODO: Wrap 'check phase with 'tests?'.
- #$@(if (not (target-ppc32?))
+ #$@(if (not (or (target-ppc32?)
+ (%current-target-system)))
#~((add-after 'install 'check
(lambda _
;; xfconfd requires a writable HOME