summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-04-06 09:34:15 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-06-03 19:56:29 +0200
commit6b09647babb50fbefaf01872c6e688f48d850e21 (patch)
tree55b5d8578a5b85b765b51bd23047a1f2d3a72edb /gnu/packages/gtk.scm
parentbe9c02ae6a4db09380fc3120ba8af3dfea14a2fb (diff)
gnu: gtk: Update to 4.14.2.
* gnu/packages/gtk.scm (gtk): Update to 4.14.2. [#:phases]<patch>: Disable new test failures. [inputs]: Add shaderc.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e77f1c208d..d5777ae67b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1140,7 +1140,7 @@ application suites.")
(define-public gtk
(package
(name "gtk")
- (version "4.12.3")
+ (version "4.14.2")
(source
(origin
(method url-fetch)
@@ -1148,7 +1148,7 @@ application suites.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "128ahzsj016vz8brd8kplhfkxg2q7wy7kndibx2qfr68yrif530l"))
+ (base32 "0wp0w259rkwf6g8sk2b9jkms47vx5gp7mfs345grx9wq53plqq12"))
(patches
(search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))
(modules '((guix build utils)))))
@@ -1220,7 +1220,16 @@ application suites.")
;; This test, 'gtk:tools / validate', started failing for
;; unknown reasons after updating mesa to 23.3.1 and xorgproto
;; to 2023.2.
- ((" 'validate',") ""))
+ ((" 'validate',") "")
+ ;; XXX: These test failures come newly from 4.14.
+ ;; Not all of them are reported upstream yet, but the text nodes
+ ;; are mentioned in
+ ;; <https://gitlab.gnome.org/GNOME/gtk/-/issues/6647>.
+ (("'glyph-subpixel-position',") "")
+ (("'subpixel-positioning',") "")
+ (("'subpixel-positioning-hidpi-nogl-nocairo',") "")
+ (("'text.*\\.node',") "")
+ (("'text-mixed-color-colrv1',") ""))
(substitute* "testsuite/reftests/meson.build"
(("[ \t]*'label-wrap-justify.ui',") "")
;; The inscription-markup.ui fails due to /etc/machine-id
@@ -1288,6 +1297,7 @@ application suites.")
python-toml
python-typogrify
sassc ;for building themes
+ shaderc
tzdata-for-tests
vala
xorg-server-for-tests))