summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-30 23:48:15 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-31 14:17:36 +0200
commit8e93e694b2ccc3563e4c3dec50bc0572f24d8b37 (patch)
tree8a84f0a0e11bddf6b36069bf53c80ce74c481e55 /gnu/packages/gtk.scm
parent5426672063aab661701819c0fd58f42ba5cec8f5 (diff)
gnu: atk: Deprecate in favor of at-spi2-core.
* gnu/packages/gtk.scm (atk): Deprecate. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm38
1 files changed, 3 insertions, 35 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 48e78146aa..93dad032cd 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -158,41 +158,6 @@ such as mate-panel and xfce4-panel.")
(home-page "https://gitlab.com/vala-panel-project/vala-panel-appmenu")
(license (list license:lgpl3))))
-(define-public atk
- (package
- (name "atk")
- (version "2.36.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1217cmmykjgkkim0zr1lv5j13733m4w5vipmy4ivw0ll6rz28xpv"))))
- (build-system meson-build-system)
- (arguments
- `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
- ,@(if (%current-target-system)
- `(#:configure-flags
- ;; introspection requires running binaries for the host system
- ;; on the build system.
- '("-Dintrospection=false"))
- '())))
- (propagated-inputs (list glib)) ; required by atk.pc
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib" ,glib "bin") ; glib-mkenums, etc.
- ("gobject-introspection" ,gobject-introspection) ; g-ir-compiler, etc.
- ("pkg-config" ,pkg-config)))
- (synopsis "GNOME accessibility toolkit")
- (description
- "ATK provides the set of accessibility interfaces that are implemented
-by other toolkits and applications. Using the ATK interfaces, accessibility
-tools have full access to view and control running applications.")
- (license license:lgpl2.1+)
- (home-page "https://wiki.gnome.org/Accessibility")))
-
(define-public cairo
(package
(name "cairo")
@@ -915,6 +880,9 @@ is part of the GNOME accessibility project.")
(define-public at-spi2-atk
(deprecated-package "at-spi2-atk" at-spi2-core))
+(define-public atk
+ (deprecated-package "atk" at-spi2-core))
+
(define-public gtk+-2
(package
(name "gtk+")