summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-23 21:09:49 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-23 21:09:49 +0200
commite38d6a9c2fba815ac34e74baa843f15e33846813 (patch)
tree0a3dd602449386119fc15de32a5cf7e5f607b2a1 /gnu/packages/gtk.scm
parentda716c8b9cdc358609a368bd5da70b31cd97a938 (diff)
parentcbd20d627497053871db863970c07d93c7081786 (diff)
Merge branch 'master' into gnome-team
Change-Id: Ib6f55bebef2fb235fa59fd5442102a3e0ace3191
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm39
1 files changed, 23 insertions, 16 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9ff1c6e2b5..21a12689b7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -808,22 +808,29 @@ ever use this library.")
#:phases
#~(modify-phases %standard-phases
(delete 'check)
- (add-after 'install 'check
- (lambda _
- (setenv "HOME" (getenv "TMPDIR")) ;xfconfd requires a writable HOME
- ;; Run test-suite under a dbus session.
- (setenv "XDG_DATA_DIRS" ;for finding org.xfce.Xfconf.service
- (string-append #$output "/share:" (getenv "XDG_DATA_DIRS")))
- ;; Don't fail on missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- (with-directory-excursion (string-append "../at-spi2-core-"
- #$version "")
- (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
- (substitute* "ci/run-tests.sh"
- (("ps auxwww") "") ;avoid a dependency on procps
- (("meson test -C _build")
- "meson test -C ../build")) ;adjust build directory
- (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))))
+ ;; The CI test suite fails completely on powerpc-linux.
+ ;; The name org.gnome.SessionManager was not provided by any .service
+ ;; TODO: Wrap 'check phase with 'tests?'.
+ #$@(if (not (target-ppc32?))
+ #~((add-after 'install 'check
+ (lambda _
+ ;; xfconfd requires a writable HOME
+ (setenv "HOME" (getenv "TMPDIR"))
+ ;; Run test-suite under a dbus session.
+ (setenv "XDG_DATA_DIRS" ;for finding org.xfce.Xfconf.service
+ (string-append #$output "/share:"
+ (getenv "XDG_DATA_DIRS")))
+ ;; Don't fail on missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ (with-directory-excursion (string-append "../at-spi2-core-"
+ #$version "")
+ (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+ (substitute* "ci/run-tests.sh"
+ (("ps auxwww") "") ;avoid a dependency on procps
+ (("meson test -C _build")
+ "meson test -C ../build")) ;adjust build directory
+ (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))
+ #~()))))
(inputs
(list bash-minimal libxml2))
(propagated-inputs