summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-13 13:52:24 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:36 +0200
commit825a7be4316d27f8f34b0cbfa4970e1886a40e29 (patch)
tree08be567f1635368af5590b15b90109e53424f81c /gnu/packages/gtk.scm
parentdd3f9a7a49616cd2db9a0cc2d4640aebde2664ef (diff)
gnu: pango: Support build for the Hurd.
* gnu/packages/gtk.scm (pango)[native-inputs]: Do not include gobject-introspection when building for the Hurd.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 5b88a9d31e..848ed91d96 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -401,12 +401,15 @@ applications.")
(list bash-minimal
zlib))
(native-inputs
- (list `(,glib "bin") ;glib-mkenums, etc.
- gobject-introspection ;g-ir-compiler, etc.
- help2man
- perl
- pkg-config
- python-wrapper))
+ (append (list `(,glib "bin")) ;glib-mkenums, etc.
+ (if (target-hurd?)
+ '()
+ (list gobject-introspection)) ;g-ir-compiler, etc.
+ (list
+ help2man
+ perl
+ pkg-config
+ python-wrapper)))
(synopsis "Text and font handling library")
(description "Pango is a library for laying out and rendering of text, with
an emphasis on internationalization. Pango can be used anywhere that text