summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-13 13:50:38 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:36 +0200
commitdd3f9a7a49616cd2db9a0cc2d4640aebde2664ef (patch)
tree78bf046711382ec817b8c9c8dd55716193714c6e /gnu/packages/gtk.scm
parent03f35ff390d5f77843d65a9df4bd763f82049d24 (diff)
gnu: harfbuzz: Support build for the Hurd.
* gnu/packages/gtk.scm (harfbuzz)[native-inputs]: Do not include gobject-introspection when building for the Hurd.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c5ec7bcdc2..5b88a9d31e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -276,11 +276,13 @@ output. Experimental backends include OpenGL, BeOS, OS/2, and DirectFB.")
;; There are all in the Requires or Requires.private field of '.pc'.
(list glib graphite2 icu4c))
(native-inputs
- (list `(,glib "bin") ;for glib-mkenums
- gobject-introspection
- pkg-config
- python-wrapper
- which))
+ (append (list `(,glib "bin")) ;for glib-mkenums
+ (if (target-hurd?)
+ '()
+ (list gobject-introspection))
+ (list pkg-config
+ python-wrapper
+ which)))
(arguments
(list #:configure-flags
#~(list "--with-graphite2"