summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:20:18 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:41:55 -0400
commit0c5c788fad88836abdc0a0dee13b3436791fb735 (patch)
tree75637daa87e2a9c2dce45f685976c98d4a53ffec /gnu/packages/gtk.scm
parent3e629738a3acd908acc510023c85db448e3553c3 (diff)
gnu: gdk-pixbuf+svg: Use invoke.
* gnu/packages/gtk.scm (gdk-pixbuf+svg): Use invoke in the 'register-svg-loader' phase.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 198810cdd6..2fd1fbbeaf 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -513,8 +513,10 @@ in the GNOME project.")
(find-files librsvg "^libpixbufloader-.*\\.so$")))
(gdk-pixbuf-query-loaders
(string-append out "/bin/gdk-pixbuf-query-loaders")))
- (zero? (apply system* `(,gdk-pixbuf-query-loaders
- "--update-cache" ,@loaders)))))))))
+ (apply invoke
+ gdk-pixbuf-query-loaders
+ "--update-cache"
+ loaders)))))))
(synopsis
"GNOME image loading and manipulation library, with SVG support")))