summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-02 10:52:24 -0500
committerLeo Famulari <leo@famulari.name>2017-02-02 10:52:24 -0500
commite8c83d04e176f205b30b3d470f22ee5e1c686331 (patch)
tree30a95626ea31414a6319b93f50eea1e69b87a619 /gnu/packages/gtk.scm
parentd9b4cbc2a168ca3d248c5abf1f1d14c1808e6a20 (diff)
parentde643f0c15677665acce73db9c28c5488e623633 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a506949aba..0a291370e7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -331,18 +331,17 @@ diagrams.")
(base32
"07hrabhpl6n8ajz10s0d960jdwndxs87szxyn428mpxi8cvpg1f5"))))
(build-system gnu-build-system)
- (inputs
- `(("gtk" ,gtk+-2)
- ;; These two are needed only to allow the tests to run successfully.
- ("xorg-server" ,xorg-server)
- ("shared-mime-info" ,shared-mime-info)))
(native-inputs
`(("intltool" ,intltool)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ;; For testing.
+ ("xorg-server" ,xorg-server)
+ ("shared-mime-info" ,shared-mime-info)))
(propagated-inputs
;; As per the pkg-config file.
- `(("libxml2" ,libxml2)))
+ `(("gtk" ,gtk+-2)
+ ("libxml2" ,libxml2)))
(arguments
`(#:phases
;; Unfortunately, some of the tests in "make check" are highly dependent