summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-10-16 21:07:48 +0800
committer宋文武 <iyzsong@gmail.com>2015-10-16 21:07:48 +0800
commit37fe56cff6d6de24914f724e45e522d8c6eb7a67 (patch)
tree8dcb5b079693e18b7a6a10259668b3cce4ef5554 /gnu/packages/gtk.scm
parentaa382d7e4673b8bdcb92f275e2c56d74d73e26d8 (diff)
gnu: at-spi2-core: Fix test failure.
* gnu/packages/gtk.scm (at-spi2-core)[arguments]: Run test with 'DBUS_FATAL_WARNINGS=0'.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e7ad56ecc6..078f0e7c84 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -402,6 +402,8 @@ in the GNOME project.")
(replace 'check
;; Run test-suite under a dbus session.
(lambda _
+ ;; Don't fail on missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
(zero? (system* "dbus-launch" "make" "check")))))))
(propagated-inputs
;; atspi-2.pc refers to all these.