summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2015-08-08 13:34:58 -0400
committerMark H Weaver <mhw@netris.org>2015-08-08 14:09:56 -0400
commit3bc4544929beffe7136b86b59d4c83d012e09b64 (patch)
treef67acd59ddb570adc7ca974e6dda83bcbd6a2d4b /gnu/packages/gtk.scm
parent3b71b36c08cbcc90efccb7e449ecdcd19ab02991 (diff)
gnu: Add gtk-doc.
* gnu/packages/gtk.scm (gtk-doc): New variable. Modified-By: Mark H Weaver <mhw@netris.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm47
1 files changed, 46 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d812af08f6..d893861735 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,10 +32,12 @@
#:use-module (guix build-system python)
#:use-module (guix build-system waf)
#:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages check)
- #:use-module (gnu packages gettext)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -44,6 +47,7 @@
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages guile)
#:use-module (gnu packages cups)
@@ -892,3 +896,44 @@ application, an input bar that is used to execute commands of the
application and the status bar which provides the user with current
information.")
(license license:zlib)))
+
+(define-public gtk-doc
+ (package
+ (name "gtk-doc")
+ (version "1.24")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "12xmmcnq4138dlbhmqa45wqza8dky4lf856sp80h6xjwl2g7a85l"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-xml-catalog="
+ (assoc-ref %build-inputs "docbook-xml")
+ "/xml/dtd/docbook/catalog.xml"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("itstool" ,itstool)
+ ("libxml" ,libxml2)
+ ("gettext" ,gnu-gettext)
+ ("bc" ,bc)))
+ (inputs
+ `(("perl" ,perl)
+ ("python" ,python)
+ ("xsltproc" ,libxslt)
+ ("dblatex" ,dblatex)
+ ("docbook-xml" ,docbook-xml-4.3)
+ ("docbook-xsl" ,docbook-xsl)
+ ("source-highlight" ,source-highlight)
+ ("glib" ,glib)))
+ (home-page "http://www.gtk.org/gtk-doc/")
+ (synopsis "Documentation generator from C source code")
+ (description
+ "GTK-Doc generates API documentation from comments added to C code. It is
+typically used to document the public API of GTK+ and GNOME libraries, but it
+can also be used to document application code.")
+ (license license:gpl2+)))