summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2016-02-24 15:31:15 +0100
committerAndy Wingo <wingo@igalia.com>2016-02-25 22:33:20 +0100
commitb4787e71aca75392f394a127a7df537a0a016b04 (patch)
tree7f2b8ae6315e438b14b004c4c44f9d657edd9c2f /gnu/packages/gtk.scm
parent2865c81c71f0e97df7c2f9a1478c1edf161b3070 (diff)
gnu: gtk-doc: Fix build.
* gnu/packages/gtk.scm (gtk-doc): Fix build.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a234b8990f..9f2e514e14 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1107,7 +1107,24 @@ information.")
"12xmmcnq4138dlbhmqa45wqza8dky4lf856sp80h6xjwl2g7a85l"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'fix-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "configure"
+ ;; The configure check is overzealous about making sure that
+ ;; things are in place -- it uses the xmlcatalog tool to make
+ ;; sure that docbook-xsl is available, but this tool can only
+ ;; look in one catalog file, unlike the $XML_CATALOG_FILES
+ ;; variable that Guix defines. Fool the test by using the
+ ;; docbook-xsl catalog explicitly and get on with life.
+ (("\"\\$XML_CATALOG_FILE\" \
+\"http://docbook.sourceforge.net/release/xsl/")
+ (string-append (assoc-ref %build-inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-1.78.1/catalog.xml \
+\"http://docbook.sourceforge.net/release/xsl/"))))))
+ #:configure-flags
(list (string-append "--with-xml-catalog="
(assoc-ref %build-inputs "docbook-xml")
"/xml/dtd/docbook/catalog.xml"))))