summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-31 22:46:32 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-31 23:02:29 +0200
commit1a51fe2768e7be1fd5eace4ef1b6d6f0b51e2e50 (patch)
tree731fa2f32ea712f79f09bd6b3e98fa7194319d1d /gnu/packages/gtk.scm
parent821664f115ca736b527851e39edbef2a04115644 (diff)
gnu: Add Guile-RSVG.
* gnu/packages/gtk.scm (guile-rsvg): New variable. * gnu/packages/patches/guile-rsvg-pkgconfig.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e826609bca..d500fc0e38 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -33,6 +33,8 @@
#:use-module (guix build-system waf)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages docbook)
@@ -632,6 +634,44 @@ graphics library with all of the benefits of Scheme: memory management,
exceptions, macros, and a dynamic programming environment.")
(license license:lgpl3+)))
+(define-public guile-rsvg
+ (package
+ (name "guile-rsvg")
+ (version "2.18.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://wingolog.org/pub/guile-rsvg/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "136f236iw3yrrz6pkkp1ma9c5mrs5icqha6pnawinqpk892r3jh7"))
+ (patches (list (search-patch "guile-rsvg-pkgconfig.patch")))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* (find-files "." "Makefile\\.am")
+ (("/share/guile/site")
+ "/share/guile/site/2.0")))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("texinfo" ,texinfo)))
+ (inputs `(("guile" ,guile-2.0)
+ ("librsvg" ,librsvg)
+ ("guile-lib" ,guile-lib))) ;for (unit-test)
+ (propagated-inputs `(("guile-cairo" ,guile-cairo)))
+ (synopsis "Render SVG images using Cairo from Guile")
+ (description
+ "Guile-RSVG wraps the RSVG library for Guile, allowing you to render SVG
+images onto Cairo surfaces.")
+ (home-page "http://wingolog.org/projects/guile-rsvg/")
+ (license license:lgpl2.1+)))
;;;
;;; C++ bindings.