summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-10-29 15:31:52 +0100
committerAndreas Enge <andreas@enge.fr>2014-10-29 21:21:48 +0100
commit27383915cefedb5c166458f3c04ace3a5df51e2f (patch)
tree7093a9236c519fb033aa3d7ac95ee937c51c5d0a /gnu/packages/gtk.scm
parentbe2c88caa0480391cbe1a72757b32ef9f119cc97 (diff)
gnu: harfbuzz: Add and enable input graphite2.
* gnu/packages/gtk.scm (harfbuzz): Add input graphite2 and enable it with the corresponding configure flag.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 8958504953..594915bc8e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -129,10 +129,13 @@ affine transformation (scale, rotation, shear, etc.)")
(build-system gnu-build-system)
(inputs
`(("cairo" ,cairo)
+ ("graphite2" ,graphite2)
("icu4c" ,icu4c)))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
+ (arguments
+ `(#:configure-flags `("--with-graphite2=yes")))
(synopsis "OpenType text shaping engine")
(description
"HarfBuzz is an OpenType text shaping engine.")