summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-03 08:30:04 +0100
committerMark H Weaver <mhw@netris.org>2016-01-04 16:11:10 -0500
commit2a6afac9055bc2cac29678b9e2ed0344cb32c39e (patch)
treefa3f868d646d1ff40ef4b6775afcf22b361a0019 /gnu/packages/gtk.scm
parentc2e87caaa6b7efb9c18c46fd4f9d4370f68c8db7 (diff)
gnu: gtk+-2: Add patch to support GUIX_GTK2_PATH.
* gnu/packages/patches/gtk2-respect-GUIX_GTK2_PATH: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gtk.scm (gtk+-2) [source]: Add patch. [native-search-paths]: Add search path for GUIX_GTK2_PATH.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f85ea1970a..d2257825e8 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -522,7 +522,8 @@ is part of the GNOME accessibility project.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0mj6xn40py9r9lvzg633fal81xfwfm89d9mvz7jk4lmwk0g49imj"))))
+ "0mj6xn40py9r9lvzg633fal81xfwfm89d9mvz7jk4lmwk0g49imj"))
+ (patches (list (search-patch "gtk2-respect-GUIX_GTK2_PATH.patch")))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
@@ -557,7 +558,11 @@ is part of the GNOME accessibility project.")
;; FIXME: re-enable tests requiring an X server
(substitute* "gtk/Makefile.in"
(("SUBDIRS = theme-bits . tests") "SUBDIRS = theme-bits .")))
- %standard-phases)))
+ %standard-phases)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GUIX_GTK2_PATH")
+ (files '("lib/gtk-2.0")))))
(synopsis "Cross-platform toolkit for creating graphical user interfaces")
(description
"GTK+, or the GIMP Toolkit, is a multi-platform toolkit for creating