summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-13 23:44:55 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-13 23:44:55 +0200
commitc3cf9d36e40713212ffc9d75aa2324ab7bad4f9b (patch)
tree1d04f8c542b78e1510a8d29163e578fe2538d81e /gnu/packages/gtk.scm
parent314a83ef1e80b47b44debc1118e38d7f761e0e7f (diff)
parentca9ea1a849d685db46adcb92449dff36427c48bd (diff)
Merge branch 'bug-17853'
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 2823ef008f..a37565f1a8 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -54,6 +54,7 @@
(inputs `(("glib" ,glib)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME accessibility toolkit")
(description
@@ -158,6 +159,7 @@ affine transformation (scale, rotation, shear, etc.)")
`(("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME text and font handling library")
(description
@@ -215,7 +217,8 @@ functions which were removed.")
("xorg-server" ,xorg-server)
("shared-mime-info" ,shared-mime-info)))
(native-inputs
- `(("intltool" ,intltool)
+ `(("intltool" ,intltool)
+ ("glib" ,glib "bin") ; for glib-genmarshal, etc.
("pkg-config" ,pkg-config)))
(arguments
`(#:phases
@@ -267,6 +270,7 @@ printing and other features typical of a source code editor.")
("libtiff" ,libtiff)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection", gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME image loading and manipulation library")
(description
@@ -353,6 +357,7 @@ is part of the GNOME accessibility project.")
("pango" ,pango)))
(native-inputs
`(("perl" ,perl)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(arguments
@@ -395,6 +400,7 @@ application suites.")
`(("libxml2" ,libxml2)))
(native-inputs
`(("perl" ,perl)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)