summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-17 16:52:46 +0200
committerMark H Weaver <mhw@netris.org>2015-12-26 11:01:01 -0500
commitfe08b6e1eb9efbf993016945d47e8a0427c385be (patch)
treedad145d0e689411174a796f38b86170e9c99f44b /gnu/packages/gtk.scm
parent4d6b8da717ae30164809605215ebf812a4a39936 (diff)
gnu: gdk-pixbuf: Update to 2.32.3. (fixes CVE-2015-4491)
* gnu/packages/gtk.scm (gdk-pixbuf): Update to 2.32.3.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 279c06294e..f85ea1970a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -385,7 +385,7 @@ highlighting and other features typical of a source code editor.")
(define-public gdk-pixbuf
(package
(name "gdk-pixbuf")
- (version "2.32.1")
+ (version "2.32.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -393,7 +393,7 @@ highlighting and other features typical of a source code editor.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1g7kjxv67jcdasi14n7jan4icrnnppd1m99wrdmpv32k4m7vfcj4"))))
+ "0cfh87aqyqbfcwpbv1ihgmgfcn66il5q2n8yjyl8gxkjmkqp2rrb"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-x11")
@@ -403,9 +403,9 @@ highlighting and other features typical of a source code editor.")
'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/Makefile.in"
- ;; XXX FIXME: This test fails on some machines with:
- ;; GLib-FATAL-ERROR: gmem.c:103: failed to allocate
- ;; 6039798016 bytes
+ ;; XXX FIXME: This test fails on armhf machines with:
+ ;; SKIP Not enough memory to load bitmap image
+ ;; ERROR: cve-2015-4491 - too few tests run (expected 4, got 2)
(("cve-2015-4491\\$\\(EXEEXT\\) ") "")
;; XXX FIXME: This test fails with:
;; ERROR:pixbuf-jpeg.c:74:test_type9_rotation_exif_tag: