summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-09-25 00:37:22 +0300
committerMathieu Othacehe <othacehe@gnu.org>2022-09-26 15:35:37 +0200
commite5871de9866937681ce021e9f01364c63d51b2f0 (patch)
treeded3ec0b185269de4e9fd6192bc3b4ef12728872 /gnu/packages/guile-xyz.scm
parent9e4164c6ffaa8e39e9a15a0cffa9293bfe28e4b9 (diff)
gnu: guile-ini: Update to 0.5.2.
* gnu/packages/guile-xyz.scm (guile-ini): Update to 0.5.2. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 56f0bb8acc..1760ba331e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4936,7 +4936,7 @@ with a FSM is being built (for example, from a Makefile.)")
(define-public guile-ini
(package
(name "guile-ini")
- (version "0.5.1")
+ (version "0.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4945,21 +4945,12 @@ with a FSM is being built (for example, from a Makefile.)")
(file-name (string-append name "-" version))
(sha256
(base32
- "0ky7sffxywc2p84q5kdsphr99q0g5gy45rj0vx7f77hwpfm2093x"))))
+ "17fbys3gsfyx4f77a2fswirx76dlr57il2z27z77wljaz777jk36"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
#:phases (modify-phases %standard-phases
- (delete 'strip)
- (add-before 'build 'generate-fsm-context
- ;; Make sure the intermediate FSM context is present
- ;; before the build.
- (lambda _
- (let ((cwd (getcwd)))
- (chdir "modules/ini/")
- (invoke "make" "GUILE_AUTO_COMPILE=0"
- "fsm-context.scm")
- (chdir cwd)))))))
+ (delete 'strip))))
(native-inputs (list autoconf automake pkg-config texinfo))
(inputs (list bash-minimal guile-3.0 guile-lib))
(propagated-inputs (list guile-smc))