summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2023-07-05 23:43:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-05 23:43:23 +0200
commit07854c91d8a4a9c20e8391cc4d07715a4cc39f23 (patch)
tree49d78f9c5b5221c78cefffaa8ba9fefe46f4bf65 /gnu/packages/guile-xyz.scm
parentebecfa55d53bde9b905f510a361bfe4f749a8f46 (diff)
gnu: guile-jsonld: Improve package style.
* gnu/packages/guile-xyz.scm (guile-jsonld): Improve overall indentation. [propagated-inputs]: Remove labels. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 7707e67f00..46555d2bc7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4671,33 +4671,31 @@ manipulating graphs and datasets.")
(package
(name "guile-jsonld")
(version "1.0.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://framagit.org/tyreunom/guile-jsonld")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ryyvh71899z2inivqglb8d78zzp1sd0wv9a56kvcmrxf1966z6r"))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://framagit.org/tyreunom/guile-jsonld")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ryyvh71899z2inivqglb8d78zzp1sd0wv9a56kvcmrxf1966z6r"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f)); require network
+ (list #:tests? #f)) ; require network
(propagated-inputs
- `(("guile-gnutls" ,guile-gnutls)
- ("guile-json" ,guile-json-4)
- ("guile-rdf" ,guile-rdf)))
+ (list guile-gnutls guile-json-4 guile-rdf))
(inputs
(list guile-3.0))
(native-inputs
(list automake autoconf pkg-config texinfo))
(home-page "https://framagit.org/tyreunom/guile-jsonld")
(synopsis "Guile implementation of the JsonLD API specification")
- (description "Guile JsonLD is an implementation of the JsonLD (Json for
-Linked Data) API defined by the W3C for GNU Guile. It allows you to express links
-between data, in a way that is very similar to WikiData or RDF for instance.
-An object can have relations (in the form of an IRI) that relates it to one or
+ (description
+ "Guile JsonLD is an implementation of the JsonLD (Json for Linked Data)
+API defined by the W3C for GNU Guile. It allows you to express links between
+data, in a way that is very similar to WikiData or RDF for instance. An
+object can have relations (in the form of an IRI) that relates it to one or
more objects or strings, represented by a Json object or an IRI.")
(license license:gpl3+)))